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Introduction 
 
The ISE JPEG Manipulator is an application designed to allow the user to examine, manipulate 
and create images from the data of pre-existing JPEG images.  Team ISE, at the University of 
Colorado at Boulder, developed this software in conjunction with a research on the topic of 
JPEG Image Selective Encryption.  The Manipulator was employed by the team to evaluate data 
from different JPEG images and provide support in testing different encryption schemes.   
 
The purpose of this manual is to inform the user about the functionality of the JPEG 
Manipulator.  Throughout the course of this manual, there will be a lot of terminology related to 
JPEG images.  Unfortunately, this manual does not explain in-depth the about how JPEG 
compression formats work and assumes that the user has some prior knowledge of these 
concepts.  If you do not have any previous experience with these types of compression formats, 
Team ISE recommends reviewing some of the reference material included at the end of this 
manual.   
 
This software is provided by Team ISE and the University of Colorado AS IS and although it is 
believed to be in good working order, said members provide no guarantees and/or warranties 
about the Usage, Quality, Stability and/or Correctness of this software.  Neither Team ISE nor 
the University of Colorado shall be held liable for any damages what-so-ever, arising out of or 
related to the use of or the inability to use the ISE JPEG Manipulator software.  Anyone 
installing, using, or having previously installed or used the JPEG Manipulator agrees to all of 
these conditions. Any user should properly back-up all data before using it in conjunction with 
the ISE JPEG Manipulator software.   
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Chapter 1: Getting Started 
Before the user can begin using the JPEG Manipulator, there are a number of tasks that must be 
accomplished. This section of the user manual is to explain the system requirements, provide 
installation instructions and opening the application.  Please read over the following information 
for a description of these details. 
  

1.1 ISE Manipulator Minimum System Requirements: 
The Manipulator has several system requirements needed as a minimum to properly install 
and run the Manipulator.  These requirements are as follows: 

 
1. Microsoft Windows NT/2000/XP Operating System. 
2. Microsoft .NET framework version 1.1. 
3. A monitor, mouse and keyboard for the host computer. 
4. 100 MB of free Hard Disk space. 
5. 300 MHz or faster CPU. 
6. 64 MB of RAM. 

 
1.2 ISE Manipulator Recommended System Requirements: 
In addition to the minimum system requirements needed for the ISE Manipulator, Team ISE 
also recommends several minimum system requirements, to ensure performance.  These 
requirements are as follows: 

 
1. 1 GHz or faster CPU. 
2. 256 MB of RAM. 

 
1.3 Installing the ISE JPEG Manipulator: 
The Manipulator comes prepackaged with a full installation script that performs all necessary 
functions to properly install the Manipulator with a minimal degree of user effort.  If a 
previous version of the Manipulator was installed prior to this installation, be sure to 
completely remove the previous version before preceding with this installation, otherwise 
this installation will not complete properly.  Uninstalling the Manipulator is covered under 
section 1.4 of this manual.  
 
If your system meets all minimum system requirements and there is no previous version of 
the Manipulator installed, you are now ready to begin the installation process.  To install the 
ISE JPEG Manipulator, complete the following steps: 

 
1. If the ISE Manipulator has not been previously downloaded, be sure to download it to the 

computer where it is to be installed to.  Be sure to save it some place that can be easily 
remembered, like your “Desktop.” 

 
2. Once the file has completed downloading, double-click on the file to begin the 

installation process. 
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3. Follow through on-screen installation instructions of the installer to successfully 
complete the installation (see figure 1.3.1).  Team ISE recommends using all of the 
default settings for installation. 

 

 
Figure 1.3.1 – JPEG Manipulator Installer Start Screen 

 
1.4 Uninstalling the ISE JPEG Manipulator: 
The Manipulator installation package also includes an uninstall script to remove all of the 
application files, if the need arises.  The uninstaller will remove all data copied and created 
during the installation process.  Please note that images created by the user or any original 
JPEG pictures used will not be removed, unless they are saved within the ISE program folder 
(the folder created in the programs files during installation).  To perform the uninstall 
process, complete the following steps: 

 
1. Go to Start >> Settings >> Control Panel 

 
2. Once you click on the “Control Panel,” you should see the contents of the Control 

Panel folder.  Double-click on the “Add/Remove Programs” icon (See figure 1.4.1).   
 

3. Within the Add/Remove Programs utility, find the “JPEG Manipulator” entry and 
click on it to highlight it in blue and then click on the “Remove” button next to it. 

 
4. Follow through the on-screen instructions to successfully complete removal of the 

application. 
 

Please note that you must uninstall any previous versions of the ISE JPEG Manipulator 
before installing any updated versions.   
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Figure 1.4.1 – Add/Remove Program Example 
 
1.5 Running the ISE JPEG Manipulator Application: 
Once the Manipulator has successfully completed installation, you should be able to 
instantiate the application without further delay.  If the default installation was chosen, then 
the program can be invoked by going to: 

 
 Start Button >> Programs >> ISE >> JPEG >> JPEG Manipulator 
 

Otherwise, if a different location for the program menu has been chosen, then go to the folder 
where the program was installed and then go to: 

  
 ISE >> JPEG >> JPEG Manipulator 
 

Once the JPEG Manipulator icon has been clicked, the program will begin execution.   
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Chapter 2: JPEG Manipulator Functionality 
 
Once you’ve successfully installed the ISE JPEG Manipulator application, you can begin to work 
with different types of JPEG images.  Although the application is designed to work specifically 
with the Baseline compression standard for JPEG images, the application should work with other 
JPEG formats as well.  This section of the manual is devoted to describing the interface and 
functionality of the JPEG Manipulator. 
 

2.1 Understanding How Data is Represented in the Application: 
Understanding the way JPEG image data is represented in the application is extremely 
important to use this as an effective tool.  When the Manipulator loads a JPEG image, the 
data is broken down into each of the frames of data and then distributes to its corresponding 
text box on the interface.  When each text box is loaded, the byte data is converted to its 
hexadecimal value in ASCII characters.  For example, if a byte has the value of: 1111 1111 
binary (0xff in Hexadecimal), then in the interface, the data will be displayed as “ff.”  If we 
look at an actual example of a Huffman table (shown in figure 2.1.1), we see that the data is 
loaded as 2 characters followed by a space for each byte of data in the table. 

 

 
Figure 2.1.1 – Example Data in the Manipulator 

 
As you can see by the picture above, there has been a change to 7 bytes of data in this 
particular Huffman table.  Note that when we make a change to the data, we must represent it 
as a character of ‘0’ to ‘9’ or ‘a’ to ‘f’ for the Manipulator to properly interpret the data we 
have changed.  Now that it has been said that data is represented in this way, we should 
mention that this is true for MOST of the text boxes, but not all.  Certain text boxes, like the 
File Comments text box, outputs the data as its byte value, which allows the user to see what 
the data actually says, not just the byte data itself.  In the following sections, each of the 
different text fields will be defined as to which way data is represented.  In most cases, the 
text fields will contain the byte data converted to the ASCII representation of its value. 

 
2.2 The Manipulator’s Main Window: 
Upon invoking the JPEG Manipulator application, the main window will be displayed for the 
user to see.  The main window is also known as the Console tab (which is described in depth 
in section 2.6) and will provide the user access to almost every function of the Manipulator.  
The main window is designed to look and feel like a standard, Windows-style application.  
Notice that there is a main menu, tab controls to switch between the different components of 
the interface and closing and sizing controls for the window itself. 
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2.3 The Main Menu of the Manipulator: 
The JPEG manipulator contains a Windows-style application menu bar for performing 
common tasks within the Manipulator.  This main menu consists of four sub-menus: File, 
Edit, View and Help sub-menus.  Each of these sub-menus is defined in this section of the 
manual.   
 

2.3.1 The File Menu: 
The File menu is the leftmost menu on the main window of the JPEG Manipulator 
application.  This menu provides the user with options to Load a Picture, Update a 
Picture, Create a New Project, Save a Project, Load a Project and Exit the application.  
Please note that all of these functions (except exiting the application) can be preformed 
on the Project sub-tab by using the buttons available.  In addition, the application can also 
be exited at any time by clicking on the “X” button on the top right of the main window 
of the application.  Figure 2.3.1 shows an example of the File menu and the following is a 
description of each of the File menu options: 

 
1. Load Picture - Allows the user to Load a new JPEG image into the manipulator as an 

original image for editing.  If there is an existing picture previously open, the user 
will be warned before the Load Picture action is taken. 

2. Update Picture - Allows the user to create a new manipulated image, based upon the 
current data in the Manipulator data fields. 

3. New Project - Clears out the current project data and picture data in the Manipulator. 
4. Open Project - Allows the user to open an existing project.  If a project is already 

open, then the user will be warned before the Open Project action is taken. 
5. Save Project - Allows the user to save all of the data currently loaded in the 

Manipulator in an SEP project file for future use. 
6. Exit - Allows the User to close the JPEG Manipulator at any time. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 2.3.1 – The File Menu 
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2.3.2 The Edit Menu: 
The Edit menu is the second from the leftmost menu on the main window of the JPEG 
Manipulator application.  This menu provides the user with options to Copy, Cut and 
Paste data to and from the system clipboard.  Please note that all of these functions can be 
preformed by keying in the combinations: ‘ctrl+c’, ‘ctrl+x’ or ‘ctrl+v’ respectively.  
Figure 2.3.2 shows an example of the Edit menu and the following is a description of 
each of the Edit menu options: 
 
1. Copy - Copies the currently highlighted text to the system clipboard. 
2. Cut - Cut the currently highlighted text and copies it to the system clipboard. 
3. Paste - Pastes any text currently on the system clipboard into the field currently 

indicated by the text cursor. 
 
 
 
 
 
 
 
 
 

 
Figure 2.3.2 – The Edit Menu 

 
2.3.3 The View Menu: 
The View menu is the second from the rightmost menu on the main window of the JPEG 
Manipulator application.  Under the View menu is the Stretch Mode sub-menu.  This sub-
menu provides the user with options to toggle each of the picture box controls between 
normal and stretch mode.  Figure 2.3.3 shows an example of the View menu and Stretch 
Mode sub-menu and the following is a description of each of the options: 
 
1. Large Original - Toggles the stretch mode for the picture box on the Original Picture 

tab. 
2. Large Manipulated - Toggles the stretch mode for the picture box on the 

Manipulated Picture tab. 
3. Small Original - Toggles the stretch mode for the Original picture box on the 

Console tab. 
4. Small Manipulated - Toggles the stretch mode for the Manipulated picture box on 

the Console tab. 
5. All Pictures - Toggles the stretch mode for each of the picture box controls in the 

Manipulator application. 
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Figure 2.3.3 – The View Menu 
 
2.3.4 The Help Menu: 
The Help menu is the rightmost menu on the main window of the JPEG Manipulator 
application.  This menu provides the user with options to view the Manipulator Tutorial, 
Manipulator User Manual (this document) and the About window.  Figure 2.3.4 shows an 
example of the Help menu and the following is a description of each of the Help menu 
options: 

 
1. Tutorial - Opens a new window containing the Manipulator’s user tutorial document. 
2. Manual - Opens a new window containing the Manipulator’s user manual document 

(i.e. this document). 
3. About - Opens a new window containing the Manipulator’s about window to display 

the application and project information. 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 2.3.4 – The Help Menu 
 
2.4 The Original Picture Tab: 
The Original Picture tab allows the user to see, in a large window, the JPEG image that is 
currently loaded in the Manipulator.  Also, this picture can be viewed in its actual size, or 
stretched to fit the exact size of the picture box control on this tab, by making changes in the 
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View menu settings (as described in section 2.3).  An example image is shown in figure 2.4.1 
(shown in stretch mode): 

 

Figure 2.4.1 – The Original Picture Tab 
 

2.5 The Manipulated Picture Tab: 
The Manipulated Picture tab allows the user to see, in a large window, the altered JPEG 
image that is currently loaded in the Manipulator.  Also, this picture can be viewed in its 
actual size, or stretched to fit the exact size of the picture box control on this tab, by making 
changes in the View menu settings (as described in section 2.3).  An example image is shown 
in figure 2.4.1 (shown in stretch mode): 
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Figure 2.5.1 – The Manipulated Picture Tab 

 
2.6 The Console Tab: 
The Console tab is the real heart of the JPEG Manipulator.  From the Console tab, the user 
can load images and projects, manipulate the data of images, create new images and save 
project data.  The Console tab provides two smaller picture boxes for viewing the original 
and manipulated images, which can also be stretched by adjusting the settings on the View 
menu.  The Console tab also has a series of sub-tabs that contain a number of text fields that 
store all of the image and project data.  An example of the Console tab is shown in the figure 
2.6.1 (note that the small original and manipulated pictures are in stretch view mode). 
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 Figure 2.6.1 – The Console Tab 
 

2.7 The Console Tab JPEG Data Sub-Tabs: 
As shown in the picture above, the Console tab has a number of sub-tabs that contain all of 
the data loaded from the JPEG image and any project information.  From these data sub-tabs, 
it is possible to change any of the data within the JPEG image.  Each of these tabs are 
described in detail in this section of the manual.  As stated in section 2.1, the data is 
represented a few different ways, depending on the type of image data that it happens to be.  
The following subsections will specify how the data for each of the data fields in the 
Manipulator is handled the data and how it will be treated when a manipulated image is 
encoded. 

 
2.7.1 The Project Sub-Tab: 
The Project sub-tab allows the user to view the path and file name of the current project 
loaded (if any) and any project notes.  Notice that the Project file name and the Project 
notes each have their own text fields.  In addition, you can see six buttons here, which 
perform some of the functionality that can be found on the main menu (as described in 
section 2.3).  Figure 2.7.1 is an example of what Project sub-tab looks like: 
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 Figure 2.7.1 – The Project Sub-Tab 
 

Notice that data stored in both of these fields can have any ASCII value and are not 
required to be entered as the hexadecimal characters as explained in section 3.1 of this 
document.  Each of the six buttons found on this sub-tab performs the each of the 
respective functions: 
 
1. New Project - Clears out the current project data and picture data in the Manipulator. 
2. Open Project - Allows the user to open an existing project.  If a project is already 

open, then the user will be warned before the Open Project action is taken. 
3. Save Project - Allows the user to save all of the data currently loaded in the 

Manipulator in an SEP project file for future use. 
4. Load Picture - Allows the user to Load a new JPEG image into the manipulator as an 

original image for editing.  If there is an existing image previously open, the user will 
be warned before the Load Picture action is taken. 

5. Save Picture - Allows the user to save the currently manipulated picture for future 
use. 

6. Update Picture - Allows the user to create a new manipulated picture, based upon 
the current data in the manipulator data fields. 

 
2.7.2 The File Information Sub-Tab: 
The File Information sub-tab contains the file names of both the original image and the 
manipulated image, the size of the original file and the file comments in the original file.  
The data contained in these fields can be any ASCII character and is not limited to 
Hexadecimal format, as outlined in section 3.1 of this document.  Also, any changed 
made to the data in the file comments will not be applied when the Manipulated image is 
generated.  Figure 2.7.2 is an example of the File Information sub-tab: 
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Figure 2.7.2 – The File Information Sub-Tab 
 

2.7.3 The Header Data Sub-Tab: 
If the current image loaded is indeed a Baseline standard compression format, then the 
compression table header data will be broken up and loaded into the fields on the Header 
sub-tab.  The information displayed here will be the SOF0 frame data (which should 
always be the ffc0 marker), the size of the data contained in the frame, the precision data, 
height and width data, the number of components and finally the component definitions.  
If the image loaded is not the Baseline standard compression format, then the Headers tab 
shouldn’t contain any of the JPEG image data. 
 
In addition, it is important to understand that the data on the Header sub-tab is 
represented as its Hexadecimal value.  This type of representation is outlined in section 
3.1 of this document and any changes made to these fields should be made in the same 
way, as the hexadecimal format of the values you wish to change the data to.  For 
example, the Marker field here should say “ff c0” which means that the binary value of 
these two bytes in the file is: “1111 1111 0110 0000.”  Also, any changes in the size of 
the data in this frame does not need to be made by the user manually as the Manipulator 
will calculate the new size of the frame (and number of components) when generating the 
manipulated image.  The picture below is an example of the Header data sub-tab: 

 

 Figure 2.7.3 – The Headers Sub-Tab 
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2.7.4 The Huffman Table Sub-Tabs: 
As mentioned previously, the Manipulator was designed specifically for use with the 
Baseline standard JPEG compression format.  This format uses the Huffman compression 
algorithm to create the entropy encoded data stream for the JPEG image.  Thus, these 
compression tables can be found on the two Huffman Table sub-tabs.  However, even if 
the image doesn’t use the baseline compression, any compression data encountered in the 
JPEG file will be stored on this sub-tab. 
 
The Huffman Table sub-tabs contain a number of text fields and buttons for the user to 
interact with the image data.  Each tab contains data fields for four tables, original and 
manipulated compression table data, the compression table maker data, and a series of 
buttons for manipulating the tables.  When a compression frame is loaded in the 
manipulator, the marker is loaded in the marker field, and then the rest of the frame’s 
data, except for the size information, is loaded into the corresponding Huffman table 
field.  The data is loaded in Hexadecimal format and any changes made to this data 
should be as hexadecimal ASCII characters that represent the values of each of the bytes 
of the data.  Section 3.1 describes in-depth how this data is represented.  Also, the size of 
the marker is purposefully removed from this table so that if the user changes the size of 
the table, then the new size data will be recalculated when the new image is generated.  
Notice that once the user tries to manipulate the values of one of the tables, the original 
data is stored in the corresponding, grayed out field just below it.  There are three buttons 
corresponding to each of these tables: 
 
1. Clear - this button clears out all of the data in the corresponding table field. 
2. Random - this button adds a random byte of data onto the end of the field. 
3. Restore - this button restores the original data from the image to the corresponding 

compression table. 
 
Figure 2.7.4 is an example of the Huffman Table 1 data sub-tab: 
 

 Figure 2.7.4 – The Huffman Tables Sub-Tabs 
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2.7.5 The Quantizer Table Sub-Tab: 
The Quantizer table sub-tab contains all of the data for the DQT frames (i.e. the 
Quantizer tables) contained in the JPEG image.  As defined by the JPEG standard, each 
of these tables should be exactly 64 bytes long for all Baseline compression images.  
Each of the Quantizer’s marker data, table data and table number is displayed here.  In 
addition, there are several buttons to interact with the data.      
 
When the Quantizer frame is loaded in the manipulator, the marker is loaded in the 
marker field, and then the rest of the frame’s data, except for the size information and the 
table information (i.e. all of the DTC coefficients) are loaded into the corresponding 
Quantizer table field.  The data is loaded in Hexadecimal format and any changes made 
to this data should be as hexadecimal ASCII characters that represent the values of each 
of the bytes of the data.  Section 3.1 describes in-depth how this data is represented.  
Also, the size of the frame is purposefully removed from this table so that if the user 
changes the size of the table (even though the Baseline standard dictates that these tables 
have exactly 64 coefficients), then the new size data will be recalculated when the new 
image is generated.  Notice that once the user tries to manipulate the values of one of the 
tables, the original data is stored in the corresponding, grayed out field just below it.  The 
three buttons corresponding to each of these tables has the following function: 
 
1. Clear - this button clears out all of the data in the corresponding table field. 
2. Random - this button adds a random byte of data onto the end of the field. 
3. Restore - this button restores the original data from the image to the corresponding 

Quantizer table. 
 
The picture below is an example of the Quantizer Table sub-tab: 
 

Figure 2.7.5 – The Quantizer Table Sub-Tab 
 

2.7.6 The Encoded Data Sub-Tab: 
The Encoded Data sub-tab contains all of the SOS frame data (i.e. Scan Header data), as 
well as up to the first 20 KB of the entropy encoded data stream.  Although there are 
fields for the original data, any changes made to the data on this sub-tab will not be 
applied to the Manipulated picture as this functionality will have to be left for a future 
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software enhancements.   Therefore, any changes made on the text fields will not be 
accounted for.  
 
When the Scan Header frame and the Entropy Encoded data is loaded in the manipulator, 
everything except the frame marker is stored on Encoded Data sub-tab.  The data is 
loaded in Hexadecimal format, although any changes made to this data will not be 
accounted for.  Section 3.1 describes in-depth how this data is represented.  Also, keep in 
mind that only the first 20 KB of the Encoded Data is shown in the encoded data field.  
Figure 2.7.6 is an example of Encoded Data sub-tab: 

 

 Figure 2.7.6 – The Encoded Data Sub-Tab 
 

2.7.7 The Application Data Sub-Tab: 
The Application Data sub-tab contains all of the data found in APP frames (i.e. 
Application Data frames) of the JPEG image.  Although there are up to sixteen 
application frames allowed in the Baseline compression standard, there are only ten 
spaces available on the Application data tab.  Since application data isn’t critical to the 
representation of the particular image, the decision was made to only include up to ten 
frames in the Manipulator (in all the random samples collected during the development of 
the Manipulator, none contained more than ten, in fact all of the images contained much 
less).  
 
When the Application Data frame is loaded in the manipulator, the marker is loaded in 
the Marker field, and then the rest of the frame’s data, except for the size information is 
loaded into the corresponding text field.  The data is loaded in Hexadecimal format and 
any changes made to this data should be as hexadecimal ASCII characters that represent 
each of the bytes of the data.  Section 3.1 describes in-depth how this data is represented.  
The size of the frame is purposefully removed from this table so that if the user changes 
the size of the table, then the new size data will be recalculated automatically when the 
new image is generated.  Figure 2.7.7 is an example of the Application Data sub-tab: 
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 Figure 2.7.7 – The Application Data Sub-Tab 
 

2.7.8 The Misc Data Sub-Tab: 
The Misc sub-tab contains the data of the rest of the possible frames allowed within a 
JPEG image.  Much of this data is not allowed for the Baseline compression standard, but 
to make sure that the Manipulator would be compliant for all standards currently defined, 
these data fields were included.  The Misc sub-tab contain data fields for the marker data 
and frame data for the restart interval frame, marker data and frame data for the number 
of lines frame, marker data and frame data for the expand image frame, marker data and 
frame data for any hierarchical progression frame, data for the Restart Mod 8 frame and a 
field for any program errors generated by the Manipulator during execution.  
 
When the frames on the Misc sub-tab are loaded in the Manipulator, the marker is loaded 
in the marker field (except for the Restart Mod 8 field), and then the rest of the frame’s 
data, except for the size information is loaded into the corresponding text field.  The data 
is loaded in Hexadecimal format and any changes made to this data should be as 
hexadecimal ASCII characters that represent the values of each of the bytes of the data.  
Section 3.1 describes in-depth how this data is represented.  The size of the frame is 
purposefully removed from these tables so that if the user changes the size of the table, 
then the new size data will be recalculated automatically when the new image is 
generated.  The picture below is an example of the Misc Data sub-tab: 
 

 Figure 2.7.8 – The Misc Sub-Tab 
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Norcen, R. and Uhl, A. Selective Encryption of the JPEG2000 Bitstream.  Research Paper.  

2003. 
 
Pennebaker, W. and Mitchell J.  JPEG Still Image Data Compression Standard. New York: Van 

Nostrand Reinhold, 1993. 
  
Podesser, M., Schmidt, H. and Uhl, A.  Selective Bitplane Encryption for Secure Transmission 

of Image Data in Mobile Environments.  Research Paper.  2002. 
 

Seo, Y., et al. Wavelet Domain Imag Encryption by Subband Selection and Data Bit Selection.  
Research Paper.  2003. 

 17


	Introduction ………………………………………………………………………………. ii
	Chapter 1: Getting Started ………………………………………………………………. 1
	Chapter 2: JPEG Manipulator Functionality …………………………………………..

